On 01-12-2016 23:02, Michael Paquier wrote:
>>> Should we also:
>>> - rename pg_switch_xlog and friends to pg_switch_wal?
>>> - rename pg_recievexlog to pg_revievewal (and others in bin/)?
>>> - rename pg_xlogdump to pg_waldump?
>> I think yes to all.

> I was hesitant to propose that, but if there is a will do move
> everything... Documentation would point to different pages if the
> utilities are renamed, so that's not helpful when comparing features
> across major releases... We may want to keep those files with their
> historical names.
It seems confusing if we rename the tool but not the documentation file
name. Let's put a blinking message in the release notes saying 'tool X
was renamed to tool Y'. The only thing we should do is add on each tool
page something like: pg_waldump (formerly called pg_xlogdump) ...

>>> - if we do rename, should we keep aliases for functions and symlinks for
>>> tools?
>> I think no.
+1. If the packager wants to do those aliases, it is up to him/her.

> =# select proname from pg_proc where proname ~ 'xlog';
>              proname
> ---------------------------------
>  pg_current_xlog_location
>  pg_current_xlog_insert_location
>  pg_current_xlog_flush_location
>  pg_xlogfile_name_offset
>  pg_xlogfile_name
>  pg_xlog_location_diff
>  pg_last_xlog_receive_location
>  pg_last_xlog_replay_location
>  pg_is_xlog_replay_paused
>  pg_switch_xlog
>  pg_xlog_replay_pause
>  pg_xlog_replay_resume
> (12 rows)
In those cases, let's keep the functions as wrappers and undocumented.
In a few releases, we could remove them without breaking softwares that
rely on them.

   Euler Taveira                   Timbira - http://www.timbira.com.br/
   PostgreSQL: Consultoria, Desenvolvimento, Suporte 24x7 e Treinamento

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to