Peter Geoghegan <p...@heroku.com> writes: > It means "another call to tuplesort_gettupleslot", but I believe that > it would be safer (more future-proof) to actually specify "the slot > contents may be invalidated by any subsequent manipulation of the > tuplesort's state" instead.
WFM. >> There are several other uses of "call here", both in this patch and >> pre-existing in tuplesort.c, that I find equally vague and unsatisfactory. >> Let's try to improve that. > Should I write a patch along those lines? Please. You might want to hit the existing ones with a separate patch, but it doesn't much matter; I'd be just as happy with a patch that did both things. regards, tom lane -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers