Thanks for the replies of Tom, Bruce, Justin, and Peter
regarding my posts and personal emails.

Just wants to provide some updates -

Summary of issues:
1. I was asked to tune a production database on client's AIX4.3.3 -
it's Postgresql 7.3.1, I can vacuum full,
but can't do analyze (hanging); it looks like I can run make
but make check hangs (I failed to provide Tom's requests about the trace
I can't do too much on client's machine);
2. I can't reproduce on my local AIX4.3.3 ( I checked instfix -i|grep ML
on both machine, the oslevel the same, patch levels are similar);
3. I can't make 7.3.2 on one of my local AIX 4.3.3 (errors posted) until
we added some oslevel-10/11 patches update; on the other hand I can make
7.3.2 very clean on another local AIX 4.3.3 with oslevel-9 (another puzzle
to me?)
4. I tried to make one locally and then
try to install on the client's AIX, here're some lesson learned -

1) first time - after install, can't start postmaster because of
Dependent module /usr/local/lib/libz.a(shr.o) could not be loaded.
        Member shr.o is not found in archive

To solve the above problem, I've to download and install the zlib from not the one from freshmeat!

2) 2nd time - I can start postmaster, but can't start psql client, it
requires (libreadline.a is not enough),
I've to download the gnu-readline source from
freshmeat to compile it not the one from!!

after the above struggling, I believe the Analyze hangs problem is solved!
My belief is some improvements should do in configure/make,
to have a partial functioned postgresql installed
on production account is not good. (Note: "make" should fail but not, IMHO,
the good news is at least "make check" hangs).

Hopefully this post will
help some AIX users.

thanks for the helps.

John Liu

> -----Original Message-----
> From: Peter Eisentraut [mailto:[EMAIL PROTECTED]
> Sent: Tuesday, April 01, 2003 3:41 PM
> To: John Liu
> Subject: Re: [HACKERS] 7.3.2 make failed on AIX4.3 using native c
> compiler
> John Liu writes:
> > make[4]: Leaving directory
> `/emrxdbs/postgresql-7.3.2/src/backend/parser'
> > cc -O2 -qmaxmem=16384 -qsrcmsg -qlonglong
> -I../../../src/interfaces/libpq -I
> > ../../../src/include -I/usr/local/include
> -DBINDIR=\"/emrxdbs/pgsql/bin\"  -
> > c -o pg_dump.o pg_dump.c
> >      2681 |                                          "COMMENT", deps,
> >             ....................................................a....
> This looks pretty bogus.  The code in around line 2681 is
>     ArchiveEntry(fout, oid, target, namespace, owner,
>                  "COMMENT", deps,
>                  query->data, "", NULL, NULL, NULL);
> deps is declared in the signature of the surrounding function:
> static void
> dumpComment(Archive *fout, const char *target,
>             const char *namespace, const char *owner,
>             const char *oid, const char *classname, int subid,
>             const char *((*deps)[]))
> The declaration of ArchiveEntry() is:
> extern void ArchiveEntry(Archive *AHX, const char *oid, const char *tag,
>              const char *namespace, const char *owner,
>              const char *desc, const char *((*deps)[]),
>              const char *defn, const char *dropStmt,
>              const char *copyStmt,
>              DataDumperPtr dumpFn, void *dumpArg);
> deps has exactly the same type in both.
> I wonder whether the const gets lost somewhere, perhaps due to something
> that configure does.
> --
> Peter Eisentraut   [EMAIL PROTECTED]

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to [EMAIL PROTECTED] so that your
message can get through to the mailing list cleanly

Reply via email to