I guess its fairly obvious in the title, but
log_autovacuum_min_duration doesn't log VACUUMs only autovacuums.

What isn't obvious is why that restruction is useful.

I say that it would be helpful to log all kinds of VACUUM, so we get
similar output from all methods of submission.

So, changes would be

1. Allow logging whether or not it is an autovacuum (attached)

2. Change name of parameter to ...
a) log_vacuum_min_duration
b) log_maintenance_min_duration and have it log CLUSTER, CREATE INDEX etc also
c) log_ddl_min_duration and just time any DDL that takes a long time
We could do any of those and they are all about as easy as one
another, though the last one will be a bigger patch, so a) might be

The following patch implements (1), but not yet (2) to allow debate.

Simon Riggs                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

Attachment: all_vacuums_log_min_duration.v1.patch
Description: Binary data

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to