Jim Nasby wrote:
> On 2/14/17 3:13 AM, Seki, Eiji wrote:
> >   +extern TransactionId GetOldestXmin(Relation rel, uint8 
> > ignoreFlags);
> My impression is that most other places that do this sort of thing just call 
> the argument 'flags', so as not to "lock in" a single idea of what the flags 
> are for. I can't readily think of another use for flags in GetOldestXmin, but 
> ISTM it's better to just go with "flags" instead of "ignoreFlags".

Thanks. I also think "flags" is better. I will rename it.

But I wonder if I should rename the defined flag names, IGNORE_A_FLAG_XXX and 
IGNORE_FLAGS_XXX because they include "IGNORE" in their name. I'm concerned 
GetOldestXmin users are difficult to know the meaning if they have general 
names, and general names will conflict to other definitions. Would you let me 
know if you have any idea?

Eiji Seki

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to