How come you didn't get a "No such function with those arguments" error that I always 
get when I do that?

planning=# create function oops (integer) returns int language pltcl as '
planning'# elog NOTICE "blah"
planning'# ';
planning=# select oops (cast('duh' as varchar));
ERROR:  Function oops(character varying) does not exist
        Unable to identify a function that satisfies the given argument types
        You may need to add explicit typecasts

Ian Harding
Programmer/Analyst II
Tacoma-Pierce County Health Department
Phone: (253) 798-3549
Pager: (253) 754-0002

>>> "Reuven M. Lerner" <[EMAIL PROTECTED]> 06/23/03 11:56PM >>>
Excellent -- thanks so much for your help.  I just tried the function
with the right arguments, and it worked just fine.

Yet more proof of named parameters being a good thing...


---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?


Reply via email to