On Fri, Aug 4, 2017 at 3:01 AM, Robert Haas <robertmh...@gmail.com> wrote:
> On Thu, Aug 3, 2017 at 1:10 AM, Masahiko Sawada <sawada.m...@gmail.com> wrote:
>> So we can remove scanned_tuples from LVRelStats struct and change the
>> variable name num_tuples to scanned_tuples. Attached updated patch.
> On second thought, I think we should just leave this alone.
> scanned_tuples is closely tied to tupcount_pages, so it's a little
> confusing to pull one out and not the other.  And we can't pull
> tupcount_pages out of LVRelStats because lazy_cleanup_index needs it.
> The current situation isn't doing any harm, so I'm not seeing much
> point in changing it.

Hmm, since I agree the current situation isn't doing any harm actually
I don't push hard for this but I'd like to still propose at least the
original patch that fixes an inconsistent in the code.


Masahiko Sawada
NTT Open Source Software Center

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to