> No, you're reading it backwards: the error is expected, but it's not
> appearing in your results.  I can duplicate this if I manually create
> database "regress_ecpg_user2" before running ecpg's installcheck,
> so I guess that's what you did.  I can find no evidence that any
> part of the PG regression tests creates such a database.

Thanks, that makes sense.  However, when I go into my database
with psql and type `drop database regress_ecpg_user2;`, the
response is "ERROR:  database "regress_ecpg_user2" does not exist".
So it seems either the tests are creating it somehow and then cleaning
it up (though I agree that I found no obvious evidence of that in the
codebase), or could I be looking in the wrong postgres install?

I think it's the same install though.  I have my postgres installing into an
install_dir/ directory.  Here's how I run configure:

CFLAGS='-O0' ./configure \
    --prefix=path/to/postgres/install_dir/ \
    --with-uuid=e2fs \
    --enable-debug \

I did notice that the test seems to create a ROLE called regress_ecpg_user2:

$ git grep -n 'regress_ecpg_user2'
src/interfaces/ecpg/test/Makefile:78:REGRESS_OPTS =
--create-role=regress_ecpg_user1,regress_ecpg_user2 $(EXTRA_REGRESS_OPTS)

Could that implicitly create a database too?  I know that I somehow have a
database named after my username / postgres role "murftown".

I ran "make installcheck-world" again, and, the result is different this
time -
a test called "misc_sanity" failed early on in the tests:

$ make installcheck-world
make -C src/test installcheck
make -C perl installcheck
make[2]: Nothing to be done for `installcheck'.
make -C regress installcheck
============== dropping database "regression"         ==============
============== creating database "regression"         ==============
============== running regression test queries        ==============
test tablespace               ... ok
test boolean                  ... ok
test char                     ... ok
test regex                    ... ok
test oidjoins                 ... ok
test type_sanity              ... ok
test opr_sanity               ... ok
test misc_sanity              ... FAILED
test comments                 ... ok
test expressions              ... ok
test insert                   ... ok
test insert_conflict          ... ok
test create_function_1        ... ok

The old failure with the missing error message is gone from
regression.diffs this time.
I've attached the new regression.diffs.


Attachment: regression2.diffs
Description: Binary data

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to