On 2017/10/04 4:27, Robert Haas wrote: > On Tue, Oct 3, 2017 at 8:57 AM, Ashutosh Bapat > <ashutosh.ba...@enterprisedb.com> wrote: >>> Regarding nomenclature and my previous griping about wisdom, I was >>> wondering about just calling this a "partition join" like you have in >>> the regression test. So the GUC would be enable_partition_join, you'd >>> have generate_partition_join_paths(), etc. Basically just delete >>> "wise" throughout. >> >> Partition-wise join is standard term used in literature and in >> documentation of other popular DBMSes, so partition_wise makes more >> sense. But I am fine with partition_join as well. Do you want it >> partition_join or partitionjoin like enable_mergejoin/enable_hashjoin >> etc.? > > Well, you're making me have second thoughts. It's really just that > partition_wise looks a little awkward to me, and maybe that's not > enough reason to change anything. I suppose if I commit it this way > and somebody really hates it, it can always be changed later. We're > not getting a lot of input from anyone else at the moment.
FWIW, the name enable_partition_join seems enough to convey the core feature, that is, I see "_wise" as redundant, even though I'm now quite used to seeing "_wise" in the emails here and saying it out loud every now and then. Ashutosh may have a point though that users coming from other databases might miss the "_wise". :) Thanks, Amit -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers