On Wed, 2006-08-09 at 18:04 -0400, Tom Lane wrote:
> >> BTW, is anyone up for renaming the existing "preload_libraries"
> variable
> >> to "postmaster_load_libraries"?  This would be more symmetrical
> with
> >> "backend_load_libraries", and so perhaps clearer about which does
> what
> > Makes sense to me, of course that breaks existing postgresql.conf
> files.
> We already broke them by removing the init-function name...

How about:

shared_load_libraries (rather than postmaster_load_libraries)
local_load_libraries (rather than backend_load_libraries)

which is more informative for people that don't know/care what a
postmaster or a backend is and what implications those phrases carry.

  Simon Riggs
  EnterpriseDB          http://www.enterprisedb.com

---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Reply via email to