In gram.y
Typename:   SimpleTypename opt_array_bounds
                {
                    $$ = $1;
                    $$->arrayBounds = $2;
                }
            | SETOF SimpleTypename opt_array_bounds
                {
                    $$ = $2;
                    $$->arrayBounds = $3;
                    $$->setof = TRUE;
                }

Typename is a generic name of type and it used in many places in gram.c, but AFAIK the single place with SETOF is a function's RETURNS declaration. So there is many checks about SETOF. May I eliminate SETOF from Typename and leave it only for RETURNS?



--
Teodor Sigaev                                   E-mail: [EMAIL PROTECTED]
                                                   WWW: http://www.sigaev.ru/

---------------------------(end of broadcast)---------------------------
TIP 2: Don't 'kill -9' the postmaster

Reply via email to