>>>> "Operator family" seems like it might be a good choice.
>>> I like this one more than opcluster. opfamily has a good ring to it also.
>> +1 on opfamily.
> Done, unless anyone really doesn't like it.

So I started revising my notes on what to change the catalog structure
to, and immediately came up with


        opfamid                 access method OID
        opfname                 family name
        opfnamespace            family namespace
        opfowner                owner's OID

But "opfamid" is a really unfortunate name, because it looks way too
much like it's supposed to be the ID of the family itself, rather than
of the index AM it's associated with.

I'm thinking of changing it to "opfmethod", and similarly rename
pg_opclass.opcamid to opcmethod.  That might break a few bits of code
that needn't be broken, but on the whole this patch will whack the
opclass-related catalogs around enough that most code looking at them
will need fixes anyway.


                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
       subscribe-nomail command to [EMAIL PROTECTED] so that your
       message can get through to the mailing list cleanly

Reply via email to