On Tue, 23 Jan 2007, Magnus Hagander wrote:

> On Tue, Jan 23, 2007 at 09:31:40AM -0500, Andrew Dunstan wrote:
> > Magnus Hagander wrote:
> > >Hi!
> > >
> > >I get failures for the largeobject regression tests on my vc++ build. I
> > >don't think this has ever worked, given that those tests are fairly new.
> > >Any quick ideas on what's wrong before I dig deeper?
> > >
> > >
> > [snip]
> >
> > I wonder if this is a line-end issue? Assuming you are working from CVS,
> > does your client turn \n into \r\n ? I see that other windows boxes are
> > happily passing this test on the buildfarm, and of course the mingw cvs
> > doesn't adjust line endings.
> Bingo!
> That's it. I copeid the file in binary mode from a linux box and now it
> passes.

I thought about that when I wrote it, and thus tried it under mingw and
cygwin without issue ;)  I don't think the regression tests were in a
position of running on the msvc build at the time...  My thought for what
to do if this did run into a problem would be an alternate output file
that is also acceptable (I don't know what they're called but other tests
have them IIRC).

Fifth Law of Procrastination:
        Procrastination avoids boredom; one never has the feeling that
there is nothing important to do.

---------------------------(end of broadcast)---------------------------
TIP 9: In versions below 8.0, the planner will ignore your desire to
       choose an index scan if your joining column's datatypes do not

Reply via email to