Magnus Hagander wrote:
On Tue, Jan 23, 2007 at 11:39:23AM -0800, Jeremy Drake wrote:
On Tue, 23 Jan 2007, Magnus Hagander wrote:

On Tue, Jan 23, 2007 at 09:31:40AM -0500, Andrew Dunstan wrote:
Magnus Hagander wrote:

I get failures for the largeobject regression tests on my vc++ build. I
don't think this has ever worked, given that those tests are fairly new.
Any quick ideas on what's wrong before I dig deeper?


I wonder if this is a line-end issue? Assuming you are working from CVS,
does your client turn \n into \r\n ? I see that other windows boxes are
happily passing this test on the buildfarm, and of course the mingw cvs
doesn't adjust line endings.

That's it. I copeid the file in binary mode from a linux box and now it
I thought about that when I wrote it, and thus tried it under mingw and
cygwin without issue ;)  I don't think the regression tests were in a
position of running on the msvc build at the time...  My thought for what
to do if this did run into a problem would be an alternate output file
that is also acceptable (I don't know what they're called but other tests
have them IIRC).
Either that, or we require a checkout using Unix style linefeeds. I've
confirmed that removing the file and checking it back out with "cvs --lf
update" works - tests pass fine.

Yet another option might be to flag that file as binary in cvs, in which
case I think cvsnt shouldn't go mess with it.

I have just run into this today while trying to get buildfarm working for MSVC. After some consideration I think an alternative result file is the best solution. I have looked at switches for cnsnt, but they are likely to be fragile at best.



---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Reply via email to