"Joshua D. Drake" <[EMAIL PROTECTED]> writes:
> Bruce Momjian wrote:
>> Added to TODO:
>> * Add idle_timeout GUC so locks are not held for log periods of time

> That should actually be transaction_idle_timeout. It is o.k. for us to 
> be IDLE... it is not o.k. for us to be IDLE in Transaction

Or "idle_in_transaction_timeout"?  Anyway I agree that using
"idle_timeout" for this is unwise.  We've been asked often enough for a
flat-out idle timeout (ie kill session after X seconds of no client
interaction), and while I disagree with the concept, someday we might
cave and implement it.  We should reserve the name for the behavior
that people would expect a parameter named like that to have.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 2: Don't 'kill -9' the postmaster

Reply via email to