Bruce Momjian wrote:
> Alvaro Herrera wrote:
> > Magnus Hagander wrote:
> > > Seems the change of the XML messages now causes more or less every
> > > buildfarm member to fail the XML test. Meaning all the ones that don't 
> > > have
> > > libxml, but that seems to be the vast majority...
> > > 
> > > Looks like a missing update to regression tests?
> > 
> > I don't think the new wording complies with the message guidelines
> > anyway, so my vote goes to revert the wording change and reach a
> > consensus about it before committing anything else.
> > 
> > I think this should be
> > 
> > ERROR: unsupported XML feature
> > DETAIL: The function foo requires libxml2 support.
> > HINT: You need to re-compile PostgreSQL with --enable-whatever-xml.
> Yes, I like your wording better.  I will make the updates to the code
> and regression tests.

OK, new wording:

        ERROR:  unsupported XML feature
        DETAIL:  This functionality requires libxml support.
        HINT:  You need to re-compile PostgreSQL using --with-libxml.

The error is all in one macro, so it has to be generic and not mention
the specific function, or xml data type.  Regression tests updated.

  Bruce Momjian  <[EMAIL PROTECTED]>

  + If your life is a hard drive, Christ can be your backup. +

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to