On Mon, 2007-04-16 at 03:48 +0200, Florian G. Pflug wrote:
> I just realized that this file isn't even in the postgresql CVS
> repo. But it _is_ part of the SVN mirror at
> https://projects.commandprompt.com/public/pgsql/repo.
> Seems to be a bug in the CVS->SVN conversion process...

The root problem is that the CVS repository is in a strange state, I
believe. The RCS file Attic/pgc.c,v has following metadata for the most
recent revision of the file:

date;  author vadim;   state Exp;
next    1.4;

AFAICS this is wrong: the file should be deleted and is in Attic/, so it
should have "state dead;" (which is the state that most of the deleted
files have for their last revision). preproc.c,v has the same error --
you could check for other files with the same problem by diff'ing a
fresh checkout from SVN with the same result from CVS. (Was this never

I think the right fix is for someone with shell access to the CVS master
to manually move ecpg/Attic/pgc.c,v to ecpg/pgc.c,v, do a fresh CVS
checkout/update, and then "cvs delete pgc.c". Similarly for preproc.c,v.


---------------------------(end of broadcast)---------------------------
TIP 9: In versions below 8.0, the planner will ignore your desire to
       choose an index scan if your joining column's datatypes do not

Reply via email to