Andrew Dunstan wrote:
> 
> mastodon and skylark just failed at the make stage due to a thinko on my
> part (now fixed). However, this is not correctly caught by the buildfarm
> script, meaning that the process invoked at this stage ('build 2>&1') is
> not exiting properly with a non-zero status on error. That needs to be
> fixed.

I was just checking this, and I'm not sure what the problem is. I tried
updating to the broken version of solution.pm (the one missing the
quotes around --with-pgport), and it works for me. Insofar that I get
errorlevel 255 set when exiting the process. Both if I run "perl
mkvcbuild.pl" and if I run "build" (yes, also for build 2>&1).

The error given is "Can't modify constant item in predecrement" and then
a compile error.

Am I testing the wrong thing? Could it be that the buildfarm script is
somehow not picking up error code 255? (in all cases where it's errors
from the vc++ tools, I think it's always errorcode 1 or 2)

//Magnus

---------------------------(end of broadcast)---------------------------
TIP 2: Don't 'kill -9' the postmaster

Reply via email to