I am done with refactoring the Index adviser code to make use of the current
planner hooks, and as part of this drive I was thinking of changing the name
of the feature/plugin too.
Since there's a possibility that the same architecture can be used by
other types of adviser plugins (materialized view adviser, query refactoring
adviser, etc...) and considering that this same code-base may be used to
develop those things (or they may be developed as part of this plugin),
would it be prudent to rename this plugin to just 'adviser' or 'pg_adviser'
instead of the current name 'index_adviser'?
[EMAIL PROTECTED] gmail | hotmail | indiatimes | yahoo }.com
17°29'34.37"N 78°30'59.76"E - Hyderabad *
18°32'57.25"N 73°56'25.42"E - Pune
Sent from my BlackLaptop device