Thank you to everyone for input on the naming of Feature "X".

The clear winner of the parameter naming was synchronous_commit, which
would imply we refer to the new feature as Asynchronous Commit in the
release notes and general discussions.

I will be now be starting to make changes throughout the patch so that
this name is used for variable names, function calls and comments. After
that I'll be working on docs for this feature, though they may not be
available until next week, given my current schedule. The docs will
include discussions of the proof of using mixed synch/asynch commits.

The ideas, in chronological order, and voices in favour of them were:

Idea: Simon Riggs
Supporters: None

Idea: Tom Lane
Supporters: Richard Huxton

Idea: Greg Stark
Supporters: Simon, Josh, Tom, Bruce, Florian

Idea: Bruce Momjian
Supporters: None

Idea: Simon Riggs
Supporters: None

Idea: Greg Smith
Supporters: None

synchronous_commit is a clear winner. Most of the names have
difficulties as to how we would refer to them when turned off: undurable
commit, unconfirmed commit, unreliable commit don't work for me, nor
does undeferred commit make sense for normal commits. Also, I can't see
our press release saying "PostgreSQL releases Unreliable Commit". :-)

  Simon Riggs             

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to