hello all ...

does anybody remember why threaded python is not allowed on some flavors of BSD?
i was surprised to read this in the configure script ...

# threaded python is not supported on bsd's
echo "$as_me:$LINENO: checking whether Python is compiled with thread support" >&5 echo $ECHO_N "checking whether Python is compiled with thread support... $ECHO_C" >&6 pythreads=`${PYTHON} -c "import sys; print int('thread' in sys.builtin_module_names)"`
if test "$pythreads" = "1"; then
  echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6
  case $host_os in
  openbsd*|freebsd*)
{ { echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5 echo "$as_me: error: threaded Python not supported on this platform" >&2;}
   { (exit 1); exit 1; }; }


is there an issue with BSD itself or is it just a matter of linking the backend against pthreads? the problem is that this is a bit of a showstopper for skytools on BSD ...

        many thanks,

                hans


--
Cybertec Geschwinde & Schönig GmbH
Gröhrmühlgasse 26, 2700 Wiener Neustadt
Tel: +43/1/205 10 35 / 340
www.postgresql.at, www.cybertec.at


Reply via email to