Alvaro Herrera <[EMAIL PROTECTED]> writes:
> Tom Lane wrote:
>> Or we could get radical and rename both of them...

> Well, it is a bit misleading to have the query_string stuff be named
> "stats" when it's not actually collected by pgstats at all.  Maybe
> rename it to "collect_query_string".  With the other name being
> "collect_stats", they would show up together in SHOW ALL.

query_string is pretty misleading these days too, since pg_stat_activity
includes a lot more than the bare query string.

If we were doing this on a blank slate I would suggest "track_stats"
and "track_activities", but that might be too different from what
people are used to.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to