"Brendan Jurd" <[EMAIL PROTECTED]> writes:
> On 8/15/07, Tom Lane <[EMAIL PROTECTED]> wrote:
>> For example, "log_line_prefix" is misnamed under this rule, and ought to
>> be "logging_line_prefix".  Similarly, redirect_stderr would become
>> "logging_something" --- I'd prefer "logging_start_collector" but could
>> live with "logging_collector" (or maybe "logging_use_collector"?)

> The consistent prefix idea sounds good; does "logging_enable" jive
> with your proposal?

I dislike it.  I claim that logging to plain stderr (without the
syslogger process) is still logging.  Logging to syslog (which also
doen't need the syslogger process) is *definitely* logging.  Something
named "logging_enable" would suggest to the normal person that without
it turned on, you'll get *nothing*.

I'm not wedded to "collector" per se, but you really cannot escape the
fact that there is one more concept in here than you wish to admit.
I think that reflecting the existence of a collector process in the GUC
names makes things clearer, not less clear.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 9: In versions below 8.0, the planner will ignore your desire to
       choose an index scan if your joining column's datatypes do not

Reply via email to