Hello everybody,

I am not that deep in Java, just playing a bit with it, using PG7.1beta from
CVS on RedHat 7.0. Going to contrib/retep/jars I tried:

[mirko@romulan jars]$ java -cp ./retepTools.jar \
uk.org.retep.xml.test.XMLExport \
-Dorg.postgresql.Driver \
Now using JDBC Driver: org.postgresql.Driver
The user property is missing. It is mandatory.
        at java.lang.Throwable.<init>(Throwable.java:84)
        at java.lang.Exception.<init>(Exception.java:35)
        at java.sql.SQLException.<init>(SQLException.java:100)
        at org.postgresql.util.PSQLException.<init>(PSQLException.java:23)
        at org.postgresql.Connection.openConnection(Connection.java:115)
        at org.postgresql.Driver.connect(Driver.java:118)
        at java.sql.DriverManager.getConnection(DriverManager.java:523)
        at java.sql.DriverManager.getConnection(DriverManager.java:205)
        at uk.org.retep.xml.test.XMLExport.<init>(XMLExport.java:55)
        at uk.org.retep.xml.test.XMLExport.main(XMLExport.java:186)
[mirko@romulan jars]$ 

to get a dump of the database. It is a bit of a pity that examples exposed
when invoked without parameters are all about oracle :-).

I tried jdbc:postgresql:mirko/mirko@localhost for -J as well, same result. I
do not see where the jdbc-url is parsed, I guess somewhere in the
pgsql-driver? Is it possible to use a url with user/db@host with PostgreSQL
at all?

I studied the jdbc-interface documentation and did not see this syntax
mentioned anywhere.

Best Regards

Reply via email to