I think one of the solutions may be to uninstall jdk1.3 and install
jdk1.2.2. I had to do that to get my stuff working. Remember, the
jdbc7.0-1.2 driver notation means you are connecting to jdk1.2, not jdk1.3.
Since you have j2sdk1.2 also, check whether /usr/bin/java points to your
jdk1.3 or jdk1.2. And if there is no /usr/bin/java or /usr/bin/javac, create
soft links for them and point them to your jdk1.2

Hope this Helps..


> -----Original Message-----
> From: Matthew Hyatt [mailto:[EMAIL PROTECTED]]
> Sent: 21 April 2001 18:01
> Subject: Another Problem Connecting to JDBC7.0
> Read several threads in this group, especially "Problem
> connecting to JDBC7.0-1.2 driver" posted by BNV Raman and Brett
> McCoy.  I've done most everything BNV Raman did, but I'm still
> not connecting.
> Background:
> + Red Hat 7.0.x
> + postgresql 7.0.3-2 (ran rpm updates using 10 rpm's directly
> from postgresql.org)
> + jdk1.3.0_02
> + j2sdkee1.2.1
> + postmaster -i (yep)
> + copied JDBC7.0-1.2.jar to postgresql.jar
> + set userconfig.sh to:
> J2EE_CLASSPATH="/usr/lib/pgsql/postgresql.jar:/usr/java/j2sdkee1.2
> .1/lib/system/postgresql.jar"
> + set /etc/profile J2EE_CLASSPATH to the same as above. I point
> to two postgresql.jar files, because it sounds like Raman left
> them in /usr/lib/psql directory, and Sun documents said to copy
> them into the ...j2sdkee.../lib/system directory.  So, I did both.
> + Did NOT set CLASSPATH, because Sun j2sdkee docs sa to remove
> CLASSPATH references
> + pgsql runs query statements, I've made and populated several databases
> + java code compiles, jsp runs (tomcat)
> + Class.forName("org.postgresql.Driver")
> "No suitable driver... error"
> Since the CLASSPATH setting is one difference between Raman's
> success, and my failures, I tried pointing to the postgresql.jar
> using -classpath when compiling, still, "No suitable driver".
> Raman and McCoy made mention of "interfaces" dir.  I cannot find
> interfaces.  I ran all the rpm's:
> postgresql-7.0.3-2.i386.rpm
> postgresql-devel-7.0.3-2.i386.rpm
> postgresql-jdbc-7.0.3-2.i386.rpm
> postgresql-odbc-7.0.3-2.i386.rpm
> postgresql-perl-7.0.3-2.i386.rpm
> postgresql-python-7.0.3-2.i386.rpm
> postgresql-server-7.0.3-2.i386.rpm
> postgresql-tcl-7.0.3-2.i386.rpm
> postgresql-test-7.0.3-2.i386.rpm
> postgresql-tk-7.0.3-2.i386.rpm
> All of the above rpm's verify.
> What did I do wrong?  Please advise, before I pull out ALL of my hair!

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
    (send "unregister YourEmailAddressHere" to [EMAIL PROTECTED])

Reply via email to