This looks like a postgres problem, since I get the same problem in psql
test=# update testbigint set fp0 = -9223372036854775808 where id = 1;
ERROR:  int8 value out of range: "-9223372036854775808"


-----Original Message-----
[mailto:[EMAIL PROTECTED]] On Behalf Of Dav Coleman
Sent: August 7, 2001 11:37 AM
Subject: [JDBC] BIGINT vs Java's long

According to the Java Language Specification,

"For long, from -9223372036854775808 to 9223372036854775807, inclusive"

Indeed, I have java code which generate random long's and println's
them, and I end up with values equal to -9223372036854775808.

I had those println's redirected to a .sql file which I ran against psql
to update some bigint columns, but I got 
    ERROR:  int8 value out of range: "-9223372036854775808"

Apparently bigint's don't like that value?

Well confused, since 8 bytes should be 8 freaking bytes, I turned to

That's when things got weird, first I tried declaring a long variable
with that value, and got a compilere error (Integer to large) or
something like that.

So I declared "long myBigint = Long.MIN_VALUE" and that compiled, but
when I tried using that value in a Statement.execute() I got the exact
same error.

Anyone know what's going on? Here's the test code, using

import java.sql.*;

public class testPGSQLbigint {

    public static void main( String[] args ) {
       try {
       } catch (java.lang.ClassNotFoundException e) {
            System.out.println( e );

       Connection db=null;
       String url = "jdbc:postgresql:abinitio2";
       try {
            db = DriverManager.getConnection(url,"dav","");
       } catch ( SQLException e ) {
            System.err.println( e );

       // the following gives a compiler error
       //long bigint = -9223372036854775808;
       long bigint = Long.MIN_VALUE;
       String sql_ = "update chembase set fp0 = "+bigint+" where id =

       try {
            Statement st = db.createStatement();
            st.execute( sql_ );
       } catch ( SQLException e ) {
            System.err.println( e );


$ java -classpath /opt/java/jars/jdbc7.0-1.2.jar:. "testPGSQLbigint"

update chembase set fp0 = -9223372036854775808 where id = 27948;
java.sql.SQLException: ERROR:  int8 value out of range:

note this runs the same in linux and win2k (using Sun's SDK)

Dav Coleman

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

Reply via email to