Andreas Pflug wrote:
> The attached patch enables libpq to be linked with ssl support (openssl 
> 0.9.7.b tested).
> Client certificates are commented out because the implementation is *nix 
> specific, regarding the location resolution of the .pem files. It needs 
> to be discussed where these files should be located. For NT/W2K and up, 
> the natural way would be using GetUserProfileDirectory, but this would 
> exclude Win9x.

Can't we check the OS version via the compiler?  Maybe not portabily
between the various compilers supported.

  Bruce Momjian                        |
  [EMAIL PROTECTED]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Reply via email to