This is an updated FAQ_SCO patch that inludes yesterday's changes, and also
the float4/float8 issue I raised.

Index: FAQ_SCO
RCS file: /projects/cvsroot/pgsql-server/doc/FAQ_SCO,v
retrieving revision 1.9
diff -u -r1.9 FAQ_SCO
--- FAQ_SCO     8 Nov 2002 16:49:15 -0000       1.9
+++ FAQ_SCO     15 May 2004 00:06:29 -0000
@@ -9,7 +9,7 @@
original author:        Andrew Merrill ([EMAIL PROTECTED])

-PostgreSQL 7.3 can be built on SCO UnixWare 7 and SCO OpenServer 5. +PostgreSQL 7.5 can be built on SCO UnixWare 7 and SCO OpenServer 5. On OpenServer, you can use either the OpenServer Development Kit or the Universal Development Kit.

@@ -23,6 +23,8 @@
*) Compiling PostgreSQL using the UDK
*) Reading the PostgreSQL man pages
*) C99 Issues with the 7.1.1b Feature Supplement
+*) --enable-thread-safety and UnixWare
+*) float4/float8 regression failures on NaN and inf I/O.

*************************************************************************** @@ -44,6 +46,8 @@ you install the correct version for your operating system, except as noted below.

+Note: on UnixWare 7.1.3 and beyond, the GCC compiler is included on the UDK
+CD as is GNUMake.

*) GNU Make
@@ -52,6 +56,9 @@
default, it installs as /usr/local/bin/make.  To avoid confusion with the
SCO make program, you may want to rename GNU make to gmake.

+As of UnixWare 7.1.3 and above, the GNU Make program is is the OSTK portion
+of the UDK CD, and is in /usr/gnu/bin/gmake.

*) Readline
@@ -149,4 +156,28 @@
error in compiling tuplesort.c referencing inline functions.

Apparently there was a change in the 7.1.2(8.0.0) compiler and beyond.
+*) --enable-thread-safety and UnixWare
+If you use the --enable-thread-safety configure flag, you *MUST* use -Kpthread
+on ALL libpq using programs.
+libpq uses pthread_* calls, which are only available with the
+-Kpthread/-Kthread flag.
+*) float4/float8 regression failures on NaN and inf I/O.
+You will see regression failures for the float4 and float8 regression
+tests on the NaN and inf I/O functions. This is due to a bug in SCO's strtod
+library function on BOTH UnixWare and OpenServer. It's slated to be fixed
+in the first maintenance / update for UnixWare 7.1.4, and probably the
+next MP/UP for OpenServer 5.0.7 (I'm not sure on the OSR side as of the time
+I'm writing this (2004-05-14).
+You might also see Join test failures due to ordering differences, and these
+are ok.

Larry Rosenman           
Phone: +1 972-414-9812                 E-Mail: [EMAIL PROTECTED]
US Mail: 1905 Steamboat Springs Drive, Garland, TX 75044-6749

Attachment: faq.patch
Description: Binary data

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to