It's nice, but currently there are a lot of ways in which psql is broken
regarding older server versions.  We should be caring about all of them
(ideal), or about none (the current situation).

There have been proposals in the past about making that happen.  You
could investigate that (please do -- I'd love to have a cross-version
psql, in the same way we have a cross-version compatible pg_dump).  The
way of your patch is certain to lead into a mantainance nightmare :-(

On Sat, Aug 07, 2004 at 10:20:19PM -0000, Greg Sabino Mullane wrote:

> +     if (pset.version < 700500000) {
> +                     fprintf(stderr, _("This server version (%d) does not support 
> tablespaces.\n"),

Alvaro Herrera (<alvherre[a]>)
<Schwern> It does it in a really, really complicated way
<crab> why does it need to be complicated?
<Schwern> Because it's MakeMaker.

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?


Reply via email to