Neil Conway <[EMAIL PROTECTED]> writes:
> Mark Kirkwood wrote:
>> +            TupleDescInitEntry(tupledesc, (AttrNumber) 5, "relblockbumber",
>> +                                                                    
>> NUMERICOID, -1, 0);

> I think this should be an int4, not numeric.

needs spell check too ;-)

More generally, BlockNumber is unsigned and so int4 is not at all an
accurate conversion.  Perhaps OID would be a good choice even though
it's horribly wrong on one level.

> Otherwise, looks good to me. Barring any objections, I'll apply this 
> with a few stylistic tweaks and the numeric -> int4 change tomorrow.

I would rather see this as a contrib module.  There has been *zero*
consensus that we need this in core, nor any discussion about whether
it might be a security hole.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Reply via email to