I wrote:
> I'm not sure whether to export skip_drive from path.c or just duplicate
> it.  If we do export it, a different name would probably be a good idea,
> as it seems too generic for a global symbol.

On reflection, there's another possibility, which is to put the test
code into path.c in the first place, defined something like

bool path_contains_parent_reference(const char *path);

This is probably better since the whole business of looking for ".."
seems like something that should be in path.c and not elsewhere.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 5: don't forget to increase your free space map settings

Reply via email to