Alvaro Herrera <[EMAIL PROTECTED]> writes:
> Why did you rename the C function nextval() to nextval_text()?

I did that deliberately to make sure I'd catch all the dependencies.
If you like we can argue about whether to undo that aspect of the
patch --- it's surely not very critical --- but my vision of the future
path of development is that the text variant will go away entirely.
So I didn't like the idea of having "nextval" and "nextval_oid";
seems like that gives pride of place to the wrong thing.

> As an unrelated note, since we are going to force an initdb for the next
> beta, it would be nice to include the 64 bit parameter to pg_control ...

See other thread.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to