Alvaro Herrera <[EMAIL PROTECTED]> writes:
> So instead of changing the names of the CommandDest enum, I'm hiding it
> from external view.

I thought renaming them was a better idea, actually.  A whole separate
include file to have one forward typedef seems pretty silly.  Nor am I
convinced that you won't break some people's code by removing the rest
of dest.h from spi.h.  Finally, for anyone who *does* need to include
dest.h, this doesn't address the underlying problem of risk of conflict
of names.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Reply via email to