Alvaro Herrera wrote:
Heikki Linnakangas wrote:
Alvaro Herrera wrote:
Here is a patch further cleaning up dummy process startup and the
bootstrap code itself a little.
Could we please call the "dummy" processes something else? Dummy
seems a bit belittling for such important things like bgwriter and the
startup process.

How about worker or helper process?

Well, sure, but the name was there before I patched it :-)  This is
mostly a code issue though, not something that shows up at all at the
user level.

Yeah. I thought now would be a good time to change since you're messing with the code anyway.

I'd be happy with something like "system process" that carries the meaning of something that's internal and important. But "system process" makes me think of the operating system.

Non-backend process would be a nice contrast to normal backend processes, but a negated word like that is awkward.

Internal process?

  Heikki Linnakangas

---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Reply via email to