> I'm looking for ways to make the patch simpler and less invasive.
Any objections to changing the name of "RedirectDead"? A RedirectDead ItemId is not really redirected, it's just a stub representing a dead tuple (the space for that tuple has been reused but an index entry may still point to the ItemId). How about "stub" or "tombstone"? -- Korry -- Korry Douglas [EMAIL PROTECTED] EnterpriseDB http://www.enterprisedb.com