"Mark Wong" <[EMAIL PROTECTED]> writes:
> As someone who has tested varying both those parameters it feels
> awkward to have a configure option for one and not the other, or vice
> versa. I have slightly stronger feelings for having them both as
> configure options because it's easier to script, but feel a little
> more strongly about having BLCKSZ and XLOG_BLCKSZ both as either
> configure options or in pg_config_manual.h. To have them such that
> one needs to change them in different manners makes a tad more work in
> automating testing. So my case is just for ease of testing.
Well, that's a fair point. Another issue though is whether it makes
sense for XLOG_BLCKSZ to be different from BLCKSZ at all, at least in
the default case. They are both the unit of I/O and it's not clear
why you'd want different units. Mark, has your testing shown any
indication that they really ought to be separately configurable?
I could see having the same configure switch set both of 'em.
regards, tom lane
Sent via pgsql-patches mailing list (firstname.lastname@example.org)
To make changes to your subscription: