> I'm now thinking you've got either a platform- or compiler-specific
> problem.  Exactly what is the hardware (the CPU not the disks)?  How did
> you build or come by the Postgres executables (compiler, configure
> options, etc)?

I've tried it on two of our machines, both HP Proliant DL580:
Production: Intel(R) Xeon(TM) MP CPU 2.80GHz (I think there are 2
physical CPUs with Hyperthreading, shows up as 4)
   6 gigs RAM
Development: Intel(R) XEON(TM) MP CPU 2.00GHz (I have vague
recollection of disabling hyperthreading on this chip because of some
other kernel issue)
  1 gig RAM

They are both running SuSE 8, 2.4.21-128-smp kernel

Compile instructions (I didn't do it myself) indicate we built from
source with nothing fancy:

tar xpvf postgresql-7.4.1.tar.bz2
cd postgresql-7.4.1
./configure --prefix=/usr/local/postgresql-7.4.1
make install
make install-all-headers

If i run 'file' on /usr/local/postgresql-7.4.1/bin/postgres :
postgres: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
dynamically linked (uses shared libs), not stripped

Thanks for all your help guys,


---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Reply via email to