In fact I do not really like iconNamed: as a name for a setter (for menu items and settings)
May be it should be iconSelector: or buildIconNamed:
because else we will confuse iconNamed: which returns an icon and iconNamed: that just sets the selector to retrieve the selector.


What do you think?


Le 12/10/16 à 13:25, stepharo a écrit :
Hi glamourers and other

Hi

I'm currently enhancing the API of Settings to propose to the users to pass not an icon but an icon named so that all the clients are not force to use. See below.

Now it would be great if Glamour could do the same.

Doru and Andrei?


menuOn: aBuilder
    "Specify the menu used when writing text."
    <contextMenu>
    <RubLineNumberMenu>
    (aBuilder item: #'Find...' translated)
        keyText: 'f';
        selector: #find;
        icon: (Smalltalk ui icons iconNamed: #smallFindIcon)

====>

menuOn: aBuilder
    "Specify the menu used when writing text."
    <contextMenu>
    <RubLineNumberMenu>
    (aBuilder item: #'Find...' translated)
        keyText: 'f';
        selector: #find;
        iconNamed: #smallFindIcon


Stef






Reply via email to