Concerning this case I just opened:
I’d like your opinion about it.
I just copy in this mail what I said on the case:
rotateBy: angle about: center
"Even though Point.theta is measured CW, this rotates with the more
conventional CCW interpretateion of angle."
I think this comment does not explain what this method does.
What should be something like:
This method returns the point obtained after rotating myself around #center
point of an #angle given as parameter. The #angle provided as parameter is
interpreted as being in radian.
Additionally, I think the name of this method is bad, maybe it should be
renamed to something more explicit like #rotateBy:around: or
Maybe, if this method is renamed as #rotateByRadians:around:, the method
#rotateByDegrees:around: should be added as well.
Doctorant à l’Université de Lille 1
Equipe Rmod, Inria
Bâtiment B 40, avenue Halley 59650 Villeneuve d'Ascq
Numéro de téléphone: +333 59 35 86 40