Thanks julien

On Mon, Feb 12, 2018 at 7:01 PM, Julien <julien.delplan...@inria.fr> wrote:
> Hello,
>
> Concerning this case I just opened:
> https://pharo.fogbugz.com/f/cases/21329/Point-rotateBy-about-has-a-bad-comment
>
> I’d like your opinion about it.
>
> I just copy in this mail what I said on the case:
>
> rotateBy: angle about: center
>     "Even though Point.theta is measured CW, this rotates with the more
> conventional CCW interpretateion of angle."
> [...]
> I think this comment does not explain what this method does.
>
> What should be something like:
>
> This method returns the point obtained after rotating myself around #center
> point of an #angle given as parameter. The #angle provided as parameter is
> interpreted as being in radian.
>
> Additionally, I think the name of this method is bad, maybe it should be
> renamed to something more explicit like #rotateBy:around: or
> #rotateByRadians:around:.
>
> Maybe, if this method is renamed as #rotateByRadians:around:, the method
> #rotateByDegrees:around: should be added as well.
>
> Cheers,
>
> Julien
>
> ---
> Julien Delplanque
> Doctorant à l’Université de Lille 1
> http://juliendelplanque.be/phd.html
> Equipe Rmod, Inria
> Bâtiment B 40, avenue Halley 59650 Villeneuve d'Ascq
> Numéro de téléphone: +333 59 35 86 40
>

Reply via email to