Le 11/03/2018 à 18:09, Javier Pimás a écrit :
Didn't work. Tried also with vmT70 and vmI70 and neither did work. Sometimes they segfault, sometimes they hang using 100% cpu. I noticed that being for pharo7 those vms seemed pretty old (aug-2017), so I tried vmTLatest70 and that one finally worked.

Oh :( Thank you for pointing that it worked with the latest 70 vm.

I must admit that I'm using directly downloaded recent vms to avoid that same segfault and not the pharo.org VMs, but the process for setting them is a bit complex. So I hoped that the problem was solved with the Pharo 7 VMs, which are newer.


On Sun, Mar 11, 2018 at 6:31 AM, Thierry Goubier <thierry.goub...@gmail.com <mailto:thierry.goub...@gmail.com>> wrote:

    Hi Javier,

    can you try with a 64 bits Pharo 7 vm
    (http://get.pharo.org/64/vm70)? The Pharo 6 64bits vm used to have
    segfaults upon code loading.



    Le 10/03/2018 à 22:59, Javier Pimás a écrit :

        Hi, I wonder if I'm doing something wrong or using a wrong version:

        I download a pharo image (spur64) from


        and a 64 bit vm from:

        get.pharo.org/64/vm61 <http://get.pharo.org/64/vm61>

        Then I try to load a git repo like this:

        ./pharo Pharo.image ../scripts/loadSqueakNOSVM.st

        where the script just says

        "Based on the same file from the pharo-vm project"

        Author useAuthor: 'LoadVMMaker' during: [
        Metacello new
                  baseline: #Nopsys;
                  repository: 'github://nopsys/CogNOS/VM-src';
                  load ].

        (Smalltalk saveAs: 'generator')
              ifFalse: [ Smalltalk snapshot: false andQuit: true ].

        and it crashes with the log pasted below. I cannot even load the
        code, any clue?



        Fetched -> BaselineOfNopsys-GitHub.1520523060 ---
        g...@github.com:nopsys/CogNOS.git[master] ---
        /CogNOS/image/pharo-local/iceberg/nopsys/CogNOS/VM-src (Libgit)
        Loaded -> BaselineOfNopsys-GitHub.1520523060 ---
        g...@github.com:nopsys/CogNOS.git[master] ---
        /CogNOS/image/pharo-local/iceberg/nopsys/CogNOS/VM-src (Libgit)
        Loading baseline of BaselineOfNopsys...
        Fetched -> SqueakNOS-VM-GitHub.1520523060 ---
        g...@github.com:nopsys/CogNOS.git[master] ---
        /CogNOS/image/pharo-local/iceberg/nopsys/CogNOS/VM-src (Libgit)
        Fetched -> BaselineOfSpur-EstebanLorenzano.4 ---
        filetree:///CogNOS/VMMaker/mc [:] --- filetree:///CogNOS/VMMaker/mc
        Segmentation fault Sat Mar 10 18:36:05 2018

        Pharo VM version: 5.0-201707201942  Thu Jul 20 20:40:54 UTC 2017
        gcc 4.6.3 [Production Spur 64-bit VM]
        Built from: CoInterpreter VMMaker.oscog-eem.2254 uuid:
        4f2c2cce-f4a2-469a-93f1-97ed941df0ad Jul 20 2017
        With: StackToRegisterMappingCogit VMMaker.oscog-eem.2252 uuid:
        2f3e9b0e-ecd3-4adf-b092-cce2e2587a5c Jul 20 2017
        Revision: VM: 201707201942
        <https://github.com/OpenSmalltalk/opensmalltalk-vm.git> $ Date:
        Thu Jul 20 12:42:21 2017 -0700 $ Plugins: 201707201942
        <https://github.com/OpenSmalltalk/opensmalltalk-vm.git> $
        Build host: Linux
        3.13.0-115-generic #162~precise1-Ubuntu SMP Fri Mar 24 16:47:06
        UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
        plugin path: /CogNOS/image/pharo-vm/lib/pharo/5.0-201707201942
        [default: /CogNOS/image/pharo-vm/lib/pharo/5.0-201707201942/]

        C stack backtrace & registers:
        rax 0x0c1c5f40 rbx 0x0c1c5dd0 rcx 0x0c1c5ff8 rdx 0x0c1c5e88
        rdi 0x0c1c5ba8 rsi 0x0c1c5ba8 rbp 0x0c1c5d18 rsp 0x0c1c60b0
        r8  0x0c1c55e8 r9  0x0c1c56a0 r10 0x0c1c5758 r11 0x0c1c5810
        r12 0x0c1c58c8 r13 0x0c1c5980 r14 0x0c1c5a38 r15 0x0c1c5af0
        rip 0x0c1c6168

        Smalltalk stack dump:
              0x7ffd0c1cbcc0 M MCWorkingCopy
        class>ancestorsFromArray:cache: 0x2b4a8a0: a(n) MCWorkingCopy class
                   0x19abee8 is not a context
                   0x1a24a80 is not a context
                   0x19abd78 is not a context
                   0x1a2c118 is not a context


-- Javier Pimás
        Ciudad de Buenos Aires

Javier Pimás
Ciudad de Buenos Aires

Reply via email to