--- Begin Message ---
"Float randomBetween: -4.1 and: 2.5
would be the most descriptive and compliant to your signature ;-)"
I also prefer #randomBetween:and: .
"Going to the class side of Float makes sense because you create a new
But I'm not so sure about putting this on the class side.
In fact, right now #atRandom is on the instance side and it's been that way
since the beginning. It would be akward to have one method of generating
random numbers on the class side and all others on the instance side. And
moving everything on the class side would break tons of code and legacy code.
Besides, random numbers have always been seen and/or dealt with as streams :
the intent was to get "the next one" in the stream, not create "a new instance"
Yahoo! Messenger: bstjean
"A standpoint is an intellectual horizon of radius zero". (A. Einstein)
--- End Message ---