Edit report at https://bugs.php.net/bug.php?id=52424&edit=1
ID: 52424 Comment by: thatthatisisthatthatisnotisnot at gmail dot com Reported by: php-bugs at majkl578 dot cz Summary: Function naming inconsistency: htmlentities() x html_entity_decode() Status: Wont fix Type: Bug Package: Unknown/Other Function PHP Version: 5.3.3 Block user comment: N Private report: N New Comment: +1 for fixing naming conventions. It would be REALLY easy for most developers to refactor. The only exception being those who created their own functions with names that would be used by php core functions. That is if something was coreFunction() and the user created core_function(/*some custom function with almost the same name*/) and the new release changed to underscores. It would be a burden on hosting companies to not break their users' software via an upgrade though. Someone with an old application and no one maintaining it could be in trouble if their host upgraded. Previous Comments: ------------------------------------------------------------------------ [2013-01-25 13:23:00] martin dot keckeis1 at gmail dot com +1 to make function name and parameters order more consistent! ------------------------------------------------------------------------ [2013-01-24 16:43:46] turneliusz at gmail dot com I think we should keep current look and feel of this low level part of PHP, functions. I don't believe PSR have anything to do with that naming conventions. It could end up with some huge proposal about moving functions to some namespaces which would be huge change. I think it's just simple renaming we have to do. A real proposal about revolution in functions could be IMO autoboxing but this is another topic. And BTW that idea about providing switches in php.int could make huge mess. Let's deprecate and in major release remove, no incompatibility with same versions of PHP due to some magic ------------------------------------------------------------------------ [2013-01-24 15:54:58] chris at cgsmith dot net It seems silly for any developer to change certain function names even though it is something in the back of there head. It comes down to, "if it isn't broke, why fix it?". But for a community this large and people that are trying out PHP and learning best practices, this needs to be done. However, there needs to be a vote on the naming conventions that are used. Perhaps following PSR-1 or PSR-2. ------------------------------------------------------------------------ [2013-01-24 14:03:43] turneliusz at gmail dot com Excuse me rasmus but WHY NOT? It's completely normal evolution process. Let's deprecated all things that have inconsistent naming in PHP 5.6 to be able to just remove them in PHP 6.0 where breaking compatibility would be possible. It would be just great to have PHP 6.0 as PHP 5.x with consistent function naming convention, with removed all of deprecated stuff. ------------------------------------------------------------------------ [2013-01-24 04:03:23] nishant dot kanitkar at gmail dot com I don't see why this can't be done. Alias the functions to a single standard and depreciate the old ones. In the next version of PHP, add a configuration toggle ALLOW_LEGACY_FUNCTIONS set to default false. If ALLOW_LEGACY_FUNCTIONS is true, all the depreciated functions work as expected. If ALLOW_LEGACY_FUNCTIONS is false, all the depreciated functions throw errors. Keep the toggle in all future versions of PHP. Eventually applications using the legacy function names will either run a search-and-replace or fall out of use. It wouldn't be too difficult to migrate if the only change is a name change. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=52424 -- Edit this bug report at https://bugs.php.net/bug.php?id=52424&edit=1