> a couple of compilers or analyzers are confused by this macro, not
> sure why, but reducing the noises at no cost help to get a better view
> in future checks.

There is a cost - now we have both zend_error_noreturn and return
statements, which is unneeded. If we say zend_error_noreturn does not
work, we should remove it and use zend_error, and not complicate the
code base. If we say zend_error_noreturn does work, then we should not
add plugs after it. Having both zend_error_noreturn and plugs only makes
code completely confusing and hard to read for everybody - why we have
return after code that we marked as noreturn? Why we have special
noreturn function if we have to use plugs anyway?

Stanislav Malyshev, Software Architect
SugarCRM: http://www.sugarcrm.com/
(408)454-6900 ext. 227

PHP CVS Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to