On Sat, Mar 9, 2013 at 6:04 PM, Hannes Magnusson <hannes.magnus...@gmail.com
> wrote:

> I'm still worried about the function name.
> It will most probably be used by other sapis in the future too.
> And I believe our naming convention says it should be
> "process_title_[set|get]".
>
> -Hannes
>
> On Thu, Mar 7, 2013 at 10:54 AM, Keyur Govande <ke...@php.net> wrote:
> > Commit:    a0a995cff356a6e7526188ad1979fac6c24b9e7e
> > Author:    Keyur Govande <kgova...@gmail.com>         Thu, 7 Mar 2013
> 18:54:34 +0000
> > Parents:   d77eb411ea5d80379ee92a908f543b91fa293383
> > Branches:  master
> >
> > Link:
> http://git.php.net/?p=php-src.git;a=commitdiff;h=a0a995cff356a6e7526188ad1979fac6c24b9e7e
> >
> > Log:
> > Support for CLI process title (
> https://wiki.php.net/rfc/cli_process_title)
> >
> > A new commit into branch 5.5
> >
> > Changed paths:
> >   M  sapi/cli/config.m4
> >   M  sapi/cli/config.w32
> >   M  sapi/cli/php_cli.c
> >   A  sapi/cli/php_cli_process_title.c
> >   A  sapi/cli/php_cli_process_title.h
> >   M  sapi/cli/php_cli_server.c
> >   M  sapi/cli/php_cli_server.h
> >   A  sapi/cli/ps_title.c
> >   A  sapi/cli/ps_title.h
> >   A  sapi/cli/tests/cli_process_title_unix.phpt
> >   A  sapi/cli/tests/cli_process_title_windows.phpt
> >
> >
> > --
> > PHP CVS Mailing List (http://www.php.net/)
> > To unsubscribe, visit: http://www.php.net/unsub.php


The names were chosen after some discussion on the internals list. The
current naming: cli_(set|get)_process_title was modeled after the CURL
methods. I'm not particularly attached to them and am OK with changing them
to cli_process_title_(set|get) if there is consensus :-)

Currently, the only other SAPI than _could_ use these new methods is FPM
but it already has its own implementation for this stuff. The intent was to
avoid any form of confusion where folks might think of using these methods
in Apache, etc., hence the word CLI in the method name.

- Keyur.

Reply via email to