I am trying to get postgresql (pg) support for php working on my RH7 box.  I
had a working binary installation of postgres 7.03.  I thought I had read
that php4 had default support for pg, but my call to pg_connect() gave me a
"Call to undefined function" error.

So, next I tried to re ./configure and add --with-pgsql=/usr/local/pgsql.
That would not compile, bombing when it looked for "postgres.h".   I did not
have the pg source (since this was a binary installation) so I installed
that next (in /usr/src, if that matters)

I deleted my existing binary installation of pg, and ran ./configure; gmake;
gmake install with no errors, and I added an entry in /etc/ld.so.conf as
stated in the pg INSTALL.   Pg is running fine with several db and I can
remotely connect, so I think thats ok.

After finishing with the source installation of pg, I re- ./configure php,
make and get the same error looking for "postgres.h"

<kludge> I then manually edited the ./configure file and added the include
path to /usr/src/postgres/install</kludge>  After this, I could successfully
make php, then make install.

I restarted apache, but I am still getting "Call to undefined function".

Any thoughts?   I'm pretty much out of ideas right now.........


Gary Huntress

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to