PHP crashes every time we run a certain batch of reports since we upgraded
from 4.0.4pl1 to 4.0.6. The report is ridiculously complex and requires a
boat-load of database queries. They ran very well on the previous versions
of PHP.

--The script tanks after the 34th query, at which point it begins
"Supplied argument is not a valid MySQL result resource."

--We have tried the script using:
*one connection for the entire script (mysql_pconnect)
*recalling mysql_pconnect() before every query without mysql_close()
*new connections for every query (mysql_connect...mysql_close)

--Same outcome with Mysql versions 3.23.39, 3.23.38 and 3.23.28

--Works perfectly well in PHP 4.04pl1, but not at all 4.06

--Debug log repeatedly contains two messages:

FATAL: erealloc(): Unable to allocate 1515870836 bytes
[Wed Jul 11 09:12:17 2001] [notice] child pid 16719 exit signal
fault (11)
- ---------------------------------------
./zend_execute.c(358) : Block 0x083FFD78 status:
zend_variables.c(62) : Actual location (location was relayed)
Beginning: OK (allocated on zend_API.c:379, 10 bytes)
End: Overflown (magic=0x2A8FCC82 instead of 0x2A8FCC84)
1 byte(s) overflown
- ---------------------------------------

I have tried lots of troubleshooting approaches, far too many to mention
now. I have also searched the mailing lists and bug reports and have read
documents all over the place, all to no avail. If I am being an idiot here,
let me know and I'll go away.

Thank you for your time and help,

Chris Chew

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to