Maybe some problems with libraries ...
Add Oracle libs to /etc/ and run ldconfig ... (RedHat distribution, I do not 
know where is the config file on Suse ...)


>>> "TDuquette" <[EMAIL PROTECTED]> 24.8.01 19:23 >>>


As anyone sucesfully compiled php4  with OCI  suport as an apache module on
a Oracle 9i database ?
if so i would be very intersted by some tips on how make it work.
i couldnt make it , on a linux Suse7.2, kernel 2.4.4

i have been able to suceffuly compile php statically,  making a symlink from to
if i run "php" as a comand interpreter for a script ,the script will
sucefully use OCI8 function.

hoever this does not seam to work for a php apache module.
apache wont start (at least for me)
i tried on the oracle apache java server, or on the suse pre installed one
i olso tried to compile php on this sytem, but using  withOCI="dir to an old
copy of oracle8" so it would really link with the v8 librarys ... it dont
works neither.

i havent tried yet to make php as static lib to build apache with it as a
static build-in module.
but this is not really an option i can have on production for that system.(i
have to use a third-party apache binary)

PHP Database Mailing List (
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to