Server version: Apache/1.3.24 (Darwin)
MySQL:  Ver 8.23 Distrib 3.23.49, for apple-darwin5.2 on powerpc
PHP version 4.1.2 from the Darwin CVS repository


After much hassle and grief, I was able to make and install PHP 4.1.2 
from the Darwin CVS source repository using this configure syntax:

./configure --with-mysql=/usr/local/mysql \
        --with-apxs=/usr/sbin/apxs \
        --with-curl=/sw \
        --with-zlib-dir=/usr/local \

However, when I ran 'apachectl configtest' I got a bunch of errors 
dealing with Undefined symbols, all of them starting with _mysql_*

So, after doing some searching investigating, I re-ran the configure 
script with the following flags:

./configure --with-mysql=shared,/usr/local/mysql \
        --with-apxs=/usr/sbin/apxs \
        --with-curl=/sw \
        --with-zlib-dir=/usr/local \

but when I ran make, the following errors showed:

*** Warning: This library needs some functionality provided by 
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module mysql.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.

but since the make wsa able to finish, I decided to try make install and 
see what happens. Upon running 'apachectl configtest' again, I  got 
Syntax OK, as expected. What I want to know is, will the issues 
mentioned in the errors cause me any troubles down the road? Or can 
these errors be safely ignored. The intended use for this server is as a 
test platform, and it will not come under any type of heavy load.

Please cc me, as I am in digest mode. TIA


PHP Database Mailing List (
To unsubscribe, visit:

Reply via email to