Here's one that will shake your head, mine's about shook off. 

Basic problem:  new site works on my box but not on dev server. Both
boxes have Apache and php loaded. New site is not loading includes and
dynamic data.

The old site copy on dev server has some main pages that include some
files when loaded and loads some dynamic data from a database. I'll call
one of the main pages pgroups.  When old pgroups gets loaded on dev
server, included files are included fine and data gets loaded.  

When I ftp over my modified pgroups - files are not included nor does
data get loaded.  The modifications are small in number, but basically
add a javascript menu to pgroup and some layers in an included file. 
I've tried commenting out the javascript code in pgroup but it still
wont add header.php which has meta tag info, plus other include file
info that does load with old script.  Done some other error checking to
basically prove that the include files are not being included on dev
server. I have also tried including the absolute path when calling the
include, which is in the same directory as pgroup anyway....

Additionally, on my box, all of the new files work fine.  All the
includes get loaded and dynamic data gets loaded.

*** my box - only thing in php.ini is register globals = ON

*** dev server - php.ini include path is commented out. But old code   
gets loaded fine.

This code was loaded and configured by someone else that got it from
phpnuke for free. Lucky me. We would start from scratch but have 11/1

I can send each page of code, pgroup.old &, both are about 3
pages long. I think we're not supposed to send attachments ?  I cant

Both boxes have Apache 1.3 and am assuming php 4 on both.

PHP Database Mailing List (
To unsubscribe, visit:

Reply via email to